PrintАртем Акулов

Полезные формулы Excel для работы с контекстной рекламой

Артем Акулов

Использование Excel значительно упрощает работу с созданием и ведением ppc-рекламных кампаний. А использование формул уже внутри Excel позволяет еще больше упростить и ускорить работу. Меньше времени тратится на рутину — больше времени для полезной работы.

Ниже рассмотрим 7 формул и приемов в Excel для работы с контекстной рекламой.

  • Удаление лишних пробелов (для ключевых слов и текстов объявлений)
  • Удаление минус-слов
  • Приведение ключевого слова к фразовому соответствию Яндекс Директ
  • Приведение ключевой фразы к модифицированному широкому соответствую Google AdWords
  • Преобразование к первой заглавной букве
  • Автоматическое создание заголовка для Яндекс Директа
  • Автоматическое создание текста объявления для Яндекс Директа

Удаление лишних пробелов

Задача: Часто получается так, что при работе с кампаниями в Excel случайно появляются лишние пробелы между словами в ключевой фразе/тексте объявления (например, 2 пробела подряд) или пробел появляется перед первым словом.

Но каждый символ на счету, ограничения на длину текстов очень жесткие что в Яндекс Директе, что в Google AdWords, что в любой другой системе контекстной рекламы.

Решение: Чтобы удалить лишние пробелы из фразы используется функция Excel «=СЖПРОБЕЛЫ()».

Удаляем лишние пробелы

Удаление минус-слов

Задача: есть выгрузка работающей кампании в Яндекс Директ, в некоторых ключевых словах используются минус-слова на уровне фраз. Нужно очистить ключевые фразы от минус-слов.

Это может понадобиться, например, для дальнейшей генерации текстов объявлений из ключевых фраз.

Решение: Выделяем ключевые слова. Используем инструмент поиска и замены Excel (CTRL+H). В поле поиска вводим следующую фразу « -*». Поле заменить оставляем пустым.

Удаление минус-слов

Все минус-слова удалены.

Приведение ключевого слова к фразовому соответствию Яндекс Директ

Задача: Есть ключевые слова в широком соответствии, необходимо привести их все к фразовому.

Решение: Используем следующую формулу. «=СИМВОЛ(34)&СЖПРОБЕЛЫ(A3)&СИМВОЛ(34)».

Формула для фразового соответствия Яндекс Директа и Google AdWords

Заодно удаляются лишние пробелы.

Эта же задача в Google AdWords решается гораздо быстрее через AdWords Editor (Редактор AdWords).

Приведение ключевой фразы к модифицированному широкому соответствую Google AdWords

Задача: Привести ключевые фразы из широкого соответствия к модифицированному широкому соответствию Google AdWords

Решение: Используем формулу «=»+»&ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A3);» «;» +»)».

Формула для модифицированного широкого соответствия AdWords

Преобразование к первой заглавной букве

Задача: Сделать первую букву ячейки заглавной. Используется для генерации заголовков и текстов объявлений. Англоязычная капитализация не подойдет (когда все буквы пишутся с заглавной), т.к. тексты писать таким образом у нас не принято.

Решение: Используем формулу «=СЦЕПИТЬ(ПРОПИСН(ЛЕВСИМВ(СЖПРОБЕЛЫ(A3)));ПРАВСИМВ(СЖПРОБЕЛЫ(A3);(ДЛСТР(СЖПРОБЕЛЫ(A3))-1)))».

Делаем первую букву большой

Автоматическое создание заголовка для Яндекс Директа

Задача: Сгенерировать заголовок объявления так, чтобы в нем содержалось ключевое слово и максимально длинная продающая добавка.

Решение: Используем следующую функцию «=ЕСЛИ(ДЛСТР(A11)<=$C$2;СЦЕПИТЬ(A11;$A$2);ЕСЛИ(ДЛСТР(A11)<=$C$3;СЦЕПИТЬ(A11;$A$3);ЕСЛИ(ДЛСТР(A11)<=$C$4;СЦЕПИТЬ(A11;$A$4);СЦЕПИТЬ(A11;$A$5))))».

Формула для заголовков Яндекс Директа и Google AdWords

Если нужно сгенерировать заголовок не для Яндекс Директа, а для Google AdWords. То формулу в С2-С5 как на скриншоте вносится корректировка. Будет не «33-В2», а «30-B2» (если в вашем объявлении AdWords включены удлиненные заголовки)

Корректирова формулы

Автоматическое создание текста объявления для Яндекс Директа

Задача: Аналогичная задача предыдущему пункту, только нужно теперь не заголовок сгенерировать, а текст объявления Яндекс Директ.

Решение:Используем формулу «=ЕСЛИ(ДЛСТР(A10)<=$C$2;СЦЕПИТЬ(A10;$A$2);ЕСЛИ(ДЛСТР(A10)<=$C$3;СЦЕПИТЬ(A10;$A$3);ЕСЛИ(ДЛСТР(A10)<=$C$4;СЦЕПИТЬ(A10;$A$4);ЕСЛИ(ДЛСТР(A10)<=$C$5;СЦЕПИТЬ(A10;$A$5);СЦЕПИТЬ(A10;$A$6)))))».

Формула для генерации текстов объявлений Яндекс Директ

Будут примеры excel-формул для контекстной рекламы — присылайте, расширим набор полезных формул.